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Installation - Server Firewall Exceptions

Problem

The firewall on the server is blocking connection attempts to the Lexacom SQL Server instance, causing database connection errors in client PCs.

or

The server has just been installed and firewall exceptions need to be granted to pre-empt the above problem.

Cause

The firewall on the server blocks connection attempts.

Resolution

To set these:

  • Ensure that the database has TCP/IP protocol and that this is set to use a static port; if this has not been done, to do this:
    • Run SQL Server Configuration Manager
    • Select Protocols for Lexacom
    • Ensure TCP/IP is ‘Enabled’; if not, right-click and select ‘Enable’
    • Right-click on TCP/IP in Protocols for Lexacom and select ‘Properties’
    • Browse to the IP Addresses tab and scroll down to the IPAll settings
    • Ensure there is no port number (including ‘0’) against TCP Dynamic Ports
    • Set the TCP Port option beneath to a static port (we advise to use port number 50000)
    • Once saved, select SQL Server Services
    • Right-click and select ‘Restart’ to SQL Server (Lexacom) and SQL Server Browser

 

  • Open the Control Panel, and go to Windows Firewall
  • Click ‘Advanced Settings’
  • Within the window that appears, click ‘Inbound Rules’ and then ‘New Rule’
  • Click Ports for Rule Type, and click ‘Next’
  • Enter the port details according to the table below and click ‘Next’, ‘Next’ again, and then enter the Port Name
  • Repeat for the second port
  • Close the Windows Firewall settings

 

 

Port Name

Port Number

Type

Lexacom TCP

50000

TCP

Lexacom UDP

1434

UDP

 

Created: 17 Feb 2015 12:08 GMT Updated: 22 Jul 2015 15:49 BST

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