Login Don’t have a login? Register 
Cookie policy: We use cookies to create the most effective website experience, find out more about them.

Support

Troubleshooting - Unable to create default data

Problem

When you run Lexacom following an update, you are presented with the following message dialog.

"Unable to create default data".

Cause

This problem occurs due to a database update dll being present in the Lexacom installation folder. This file was present to update older versions of Lexacom but is no longer required. 

During the update process, the update tool deletes all files that are present in the Lexacom installation folder. If for any reason a file is "locked" or in use, Lexacom cannnot delete it and continues with the update process.

This file has been superceded by another database update dll and can be safely removed.

Resolution

In order to resolve this issue, please follow the guide below:

Resolution One

  • Browse to the Lexacom installation folder, typically here:
    • Windows XP - "C:\\Program Files\\Aprobrium\\Lexacom 3"
    • Windows Vista or 7 -  "C:\\Program Files (x86)\\Aprobrium\\Lexacom 3"
  • Locate the file named Lexacom.DatabaseUpdate.dll
  • Delete the file
  • Double click on the Lexacom icon to launch Lexacom again. 
Resolution Two
  • Open an Internet Explorer window and browse to the following location
  • At the prompt select "run"
  • A dialog may warn you about running potentially unsafe programs from the internet, click yes to continue running the file.
  • You should now be presented with a black screen that states a file will be deleted.
  • Press space to continue with the process then space again to close the application.
  • Double click on the Lexacom icon to launch Lexacom again.

Created: 16 Jul 2013 10:06 BST Updated: 23 Jul 2015 09:51 BST

Back