Login Don’t have a login? Register 
Cookie policy: We use cookies to create the most effective website experience, find out more about them.

Support

SQL - Letter Types and Specialties not visible

Problem

Pre-existing Letter Types and Specialties are set to Active = 0 when updating to 3.2.1.8 from earlier versions of Lexacom 3.2.x.y

Version Affected

3.2.1.8   (when updating from 3.2.x.y only)

Cause

For pre-existing databases, when the Active column is added to Letter Type and Specialty tables during schema update, the row values are set to false.

Resolution

  1. Download QueryExpress from the following location: http://www.albahari.com/QueryExpress.exe
  2. Copy QueryExpress.exe to any client machine
  3. Open QueryExpress and enter the serverinstance name into the Server box. Select SQL Server Authentication, and enter the username and password. Click Connect.
  4. Once the main application window has appeared, select the Lexacom database from the dropdown.
  5. Paste the following script into the query window, and execute by clicking the green button.

 

UPDATE LetterType SET Active = 1 WHERE Active = 0;

SELECT * FROM LetterType;

 

UPDATE Specialty SET Active = 1 WHERE Active = 0;

SELECT * FROM Specialty;

 

  1. Check the two ‘result-set’ tabs to confirm that all rows have the Active column set to true. Finally, reload the application to confirm now working.

Created: 6 Jun 2013 13:36 BST Updated: 23 Jul 2015 09:51 BST

Back