Support
SQL - Letter Types and Specialties not visible
Problem
Pre-existing Letter Types and Specialties are set to Active = 0 when updating to 3.2.1.8 from earlier versions of Lexacom 3.2.x.y
Version Affected
3.2.1.8 (when updating from 3.2.x.y only)
Cause
For pre-existing databases, when the Active column is added to Letter Type and Specialty tables during schema update, the row values are set to false.
Resolution
- Download QueryExpress from the following location: http://www.albahari.com/QueryExpress.exe
- Copy QueryExpress.exe to any client machine
- Open QueryExpress and enter the serverinstance name into the Server box. Select SQL Server Authentication, and enter the username and password. Click Connect.
- Once the main application window has appeared, select the Lexacom database from the dropdown.
- Paste the following script into the query window, and execute by clicking the green button.
UPDATE LetterType SET Active = 1 WHERE Active = 0;
SELECT * FROM LetterType;
UPDATE Specialty SET Active = 1 WHERE Active = 0;
SELECT * FROM Specialty;
- Check the two ‘result-set’ tabs to confirm that all rows have the Active column set to true. Finally, reload the application to confirm now working.
Created: 6 Jun 2013 13:36 BST Updated: 23 Jul 2015 09:51 BST
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